Please sign in to post.

Problem with T mobile Netherland Messages App

I have moved to the Netherlands. I replaced my T-Mobile US account with a Dutch T-Mobile account. New SIM card, new phone number, same phone, Samsung S9. It works perfectly except when trying to send or receive text messages via the Messages app. Not all, but some. I cannot figure out why it doesn't like some of my US friend's phones.
I've gone through all of the settings. No one is blocked. I've added a +1 before all their numbers. Nothing works.
Any ideas?

Posted by
8889 posts

You just put +1 {area code} {number} For example +1 555 765 4321.
The confusion is that you use "1" in the USA for calls to different area codes (0 in Europe), which is confusingly the same as the country code for the USA.
You have to replace the "different Area" prefix (1 in US or 0 in Netherlands) with the "different country" prefix (+ or 00 from a landline) and then country code (1 for USA).

Posted by
11261 posts

I don't know the answer for sure, but looking at my Galaxy S9 on T-Mobile US, I went to my Messages app, then Settings, then More Settings, then Text Messages. Under Message Center, it has the number +12063130004. I assume this only works with T-Mobile US; maybe it needs to be changed to work with T-Mobile NL?

Try going into a T-Mobile store there, and ask the employees to check their phones. You can see what their Message Center number is.

Posted by
361 posts

Are you getting any kind of error message or automated response message when you try and text those numbers? Or does your phone just say "sending..." forever? Or does it seem like they're going through, but in fact those friends aren't receiving your texts or you're not receiving theirs?

Posted by
408 posts

I was getting an "unable to send" message, but now it seems to be working. Except for my friend who has an ancient flip phone! Good enough is good enough. Thanks.

Posted by
5203 posts

Different carrier (Google Fi) but I found I had to change (or add an "other" number) with an 00 in addition to the 1- area code- number in order to get numbers to work, whereas with a previous carrier, they must have a way of adapting to international calling without the addition. Of course now I also need to always dial 1 even with local numbers.