Please sign in to post.

airalo esim problem

Some imessages are coming through but many are not. Any ideas? Thanks.

Posted by
7031 posts

It would help to have more information.

What kind of phone do you have? iPhone or Android
What kind of messages? Regular iPhone messages or plain texts
When you say that some are coming through, but not many, can you give more details?

Also, you can easily contact Airalo for help and they will get back with you, usually relatively quickly. https://www.airalo.com/more-info/contact

Posted by
10 posts

Thanks, Mardee. It is an iphone 13. My daughter is in France with an airalo data sim, and verizon cellular/sim/data roaming turned off. She reports that some imessages (not talking about plain texts here) are not arriving. She thinks that when she sends an imessage (to an iphone recipient), she is able to receive their imessage replies. But when someone sends her an imessage from an iphone in the US (not as a reply to her prior message), the imessages are not arriving. She is concerned about not receiving those imessages, and also about whether they will ever be retrievable.
We have asked airalo and waiting for a response,
Thanks again!

Posted by
679 posts

Have her look into the settings for the airalo eSIM . It could be labeled as secondary, travel, other, etc. Specifically for that eSIM data roaming needs to be turned on. This is a different setting than for the Verizon sim which may be labeled as primary. That data roaming must remain off. The link below provides additional information. Hope this helps.

https://www.airalo.com/blog/3-ways-to-install-an-esim-on-iphone

“ How To Turn on Your eSIM Line

Go to your device Settings > Cellular or Mobile
Tap your eSIM line.
Toggle ON Turn On This Line.
Toggle ON Data Roaming.
Your iPhone will automatically connect to a supported network. “

Posted by
679 posts

If the above steps did not correct the problem then she may need to reset the eSIM using the following steps. I use an iPhone 13 mini for travel. The below was my last effort to get my eSIM working properly. I was not disappointed.

  1. Open Settings
  2. Go to 'Cellular' and select the appropriate eSIM data plan
  3. Tap 'Network Selection', and on the following screen, switch Automatic to OFF. In a few moments, a list of available networks will appear.
  4. Manually select the appropriate carrier

After selecting a network wait up to 10-15 minutes to get a data connection. If you are not getting a connection after 10-15 minutes toggle Airplane Mode off and on again to reset the connection.