Please sign in to post.

Easyjet website problem

I've been following plane fares for awhile, getting a feel for costs and routes (yes I know everything will change before next fall so not booking for several months). When I looked at Easyjet yesterday, bookmarked on my computer in Chrome and iPhone also putting them into search using Google and Bing, I am getting the same weird error message and unable to access their site:

Access Denied
You don't have permission to access "http://www.easyjet.com/en" on this server.
Reference #18.9df00f17.1631889714.c86b76

Easyjet app is working on my iPhone. I just can't get to their website. Does anyone have an idea what's going on? Is it an Easyjet problem? I don't think it's a computer problem since I was originally able to bookmark it, plus my computer is Dell with Windows 10 and my phone is an iPhone and I tried two browsers.
Thanks for your help.

Posted by
1850 posts

It’s not EasyJet because I can access the site.

It’s something to do with the connection between your PC, browser, network or ISP.

Clear cache & browsing history from Chrome > Settings > History > Clear data

Turn off a VPN (if you're using one)

Check your proxy settings Windows 10 Settings > Network & Internet > Proxy > Automatically Select settings (ON); Manual Proxy Set up OFF

Are you using an anti-virus programme? Switch off temporarily.

Check Windows 10 is up to date

Posted by
2466 posts

No it is the Easy Jet US site. I get access denied as well.

Posted by
4752 posts

EasyJet’s financial position is better than most in that sector, so I wouldn’t discount flying with them. I would sooner book with EasyJet than Wizz Air.

I can access EasyJet U.K., so it sounds like an issue with American access.

Posted by
4600 posts

It may be your browser. We do most of our internet activity using Stan's laptop, which uses Linux and Firefox. When I tried to book a flight on EasyJet using his computer, I got the same message you report.

I had to use my tablet, running Android and Google's browser, to book our flight.

Oddly enough, I get the same message when I try to book a multicity flight on American Airlines on the laptop.

Posted by
1250 posts

Glad to know it isn't just me but more like an Easyjet US problem. I'll watch them for a few months. Trip isn't until September 2022 so I have lots of time. Jane, I did not have the error message on American's website.

The reason I started looking at Easyjet, Nice to Venice, was to reconsider a bit of my itinerary which would skip Milan and add a night to Venice. My original plan is to take the train from Nice at the end of the RS South of Italy tour on Friday to Milan overnight before going to Venice the next day. I need to be in Venice on Saturday for an early morning day trip to Lipica on Sunday (not optional and not giving up seeing the Lippizan horses). Since I've never been to Milan, I figure an afternoon and evening are better than never seeing it. Looks like I'm may be better off sticking to my original plan.

Thanks,
Kathy

Posted by
9801 posts

It's the US site that is having problems. Some sites block ISP's from outside their home country.

Posted by
4600 posts

horsewoofie, the flight from Nice to Venice is the one I booked. We're heading to Italy between the Loire Valley to the South of France tour, and the Best of South Italy tour.

Frank II, I was able to access the site and book our flight using a different browser. I don't dispute that it's a US/Easyjet problem, but evidently there's a bit more to it.

I've had this happen before. I used to have to go to the library to file our taxes, because the IRS site didn't support what we were using. Luckily, that changed after a couple of years.

Posted by
193 posts

Same problem with Safari. I just booked my flight with the app with no issues.

Posted by
6 posts

Tried accessing easy jet site via browser (from us) and got denied error. Connected to vpn (uk based servers) and accessed easy jet via browser with no issue.

Might simply be a misconfiguration somewhere in their network or it could be intentional.

Posted by
1 posts

Thank goodness I found this thread, I too have not been able to access the website lately and it IS time for me to book flights. Thanks for reminding me to use the app, got everything all set!

Posted by
4600 posts

Oh, great. Now I can't access American Airlines flight screen, even for a round-trip itinerary on our laptop. I can still do it on my tablet.

Interestingly though, if I go through Google flights and choose the AA itinerary, it takes me right to the AA website and I can choose my flights.